Meltdown/Spectre Security Statement

We’ve released a security statement on the Meltdown and Spectre vulnerabilities as they relate to BrightSign players and the BrightSign Network. We will release further vulnerability/mitigation information as it becomes available.

Have more questions? Submit a request


Please sign in to leave a comment.
Can't find what looking for? Try to
Powered by Zendesk