Bug Announcement: Twitter Compatibility Issues

UpdateThis issue is resolved in BrightAuthor versions 3.7.0.31 and later.

Twitter recently updated their API to version 1.1, which features a new endpoint authentication system for feeds. This authentication system is not fully compatible with the current version of BrightAuthor. As a result, you cannot add a Twitter feed to a new presentation, and feeds in currently active presentations are not working.

We are currently developing a fix for this issue. Since credentials are now required for accessing a Twitter feed, you will need to re-add Twitter feeds to presentations (and republish those presentations to your players) after installing the BrightAuthor version containing the fix.

The fix will be announced here on the Support Homepage once it is available. You will also be able to find it on the Software Downloads page. 

Have more questions? Submit a request

45 Comments

  • 0
    Avatar
    JohnLBV

    Any updates on a solution to this issue?

  • 0
    Avatar
    Walter

    I haven't seen any updates from them yet...  but I did notice there is a new Twitter account referencing BrightSign and testing on the 21st... -  https://twitter.com/BrightSignTwitt

  • 0
    Avatar
    JohnLBV

    OK - so I downloaded BrightAuthor 3.7.0.12 Beta Release June 25, 2013.

    I deleted the old twitter feed from the Ticker Zone Playlist, and tried to re-add the twitter feed, but no matter what valid twitter user name I use, I get the following message now:

    Unable to access the feed associated with the specified Twitter user name. Check the user name or try a new one.

    Any ideas on what the problem is, or is it still not fixed in BA 3.7.0.12???

    Please advise, so I can advise angry clients.

    Thanks!

    John

  • 0
    Avatar
    Walter

    John,

    I can confirm the same behavior here with the recently released 3.7.0.12

    Creating a new blank project, adding a ticker zone, and then trying to add a Twitter feed, I get the same error message - "Unable to access the feed associated with the specified Twitter user name.  Check the username or try a new one."

     

    BA release notes clearly say "Twitter feeds are now interpreted with JSON", but it isn't working so far...

     

    Walter @ p-egd

  • 0
    Avatar
    BrightSign TechDocs

    The beta version of BrightAuthor posted on June 25 does not include a fix for the Twitter incompatibility bug. We are still testing the Twitter fix, and we'll be releasing a BrightAuthor version with this fix soon.

  • 0
    Avatar
    JohnLBV

    Well I downloaded the Beta (perhaps should be called ALPHA) BA 3.7.0.13 and 4.6.45 firmware for an HD220.

    The HD220 worked fine with the older published project after updating the firmware to 4.6.45.

    I loaded that project into BA 3.7.0.13 - deleted the twitter feed, re-added it and went through the authentication process, which seemed to work fine.  Published the new project, uploaded to my server (Simple File Network), and now that unit is stuck in a continuous reboot now, and is not displaying anything at all.

    Do I have to re-create the entire project again?  If so, why is it that newer version of BrightAuthor seem to keep doing this?  It should be able to load older projects, and then ask if you want to convert to newer version.  It's getting troublesome having to recreate projects all the time because of updates to BA.

    Also of note to others, BrightAuthor is using Internet Explorer to do the Twitter Authentication to your Twitter Account.  So if you use different browsers for different Twitter Accounts, keep this in mind.  

    Also of note to others, your BrightSign player will be considered an Application, using your Twitter Account (the one that you Authenticate with), and it's access will be counted towards your API rate limit along with other Applications you already have authorized on your account.  If you are a heavy Twitter User, you may want to consider a separate Twitter Account for the BrightSign Player to avoid seeing Rate Limit Exceeded messages on your account.

    As well, as I haven't gotten this to work on one unit yet, I am not sure how the Authentication handles on multiple BrightSign Players.  So I don't know if you authenticate a 2nd player on the same Twitter account, is that added, and or is the 1st authentication then revoked??

    More on this when I have time to figure out what is going on and actually get this working.

    John

  • 0
    Avatar
    Walter

    I have been testing 3.7.0.13 as well...

    I first tried a new blank presentation, created a single ticker zone, added/authorized Twitter, and the feed worked as expected.

    I then tried again by deleting the Twitter feed, and adding a new one using @CNN's tweets.  This is a bit awkward since BA pre-fills the authentication form with the username you entered, but you can enter your credentials and pull another user's feed.  This worked fine as well.

    I then opened our main demo presentation - two of three zones are not shown in BA, and no longer display when published to the device! (XD1030)

    The only time I was able to get the device to fail with the blinking error light was on purpose when I tested loading a presentation using BA 3.7.0.13 on to a device with firmware 4.4.44 - I didn't expect that to work, and it doesn't.

    As for the rate limit, it looks like the default is 180 requests per 15 minutes.  I'm not sure if BA/BrightSign would qualify for the application authentication, but that may be a better route.

     

    Walter @ p-egd

  • 0
    Avatar
    Walter

    I'm not a fan of using IE in the auth window either, it should respect the default system browser.

     

    Walter @ p-egd

  • 0
    Avatar
    BrightSign TechDocs

    Also, please note that BrightAuthor 3.7.0.13 and firmware version 4.6.45 _are _pre-beta builds and are meant for testing only. We haven't released them to the public yet because there may be instabilities that will break things unexpectedly.

  • 0
    Avatar
    JohnLBV

    So far the only way it has worked for me is a brand new presentation.

    Any of my existing presentations with a Twitter feed in it, where I deleted the existing twitter feed, and loaded a new one, have resulted in the player continuously rebooting.  I doesn't even stay on long enough to log into the web interface to see what may be causing the issue. And nothing but black screens.

    So I would have to say BA 3.7.0.13 is definitely not ready for Prime Time.

    Now to let my clients know there isn't going to be a fix anytime soon.

     

    The Application Authentication is mandatory now with the newer Twitter API.  BrightSign didn't really have a choice, but Twitter gave plenty of warning that the older API was going away (September 2012), and that people needed to re-write their applications for the newer API by March 2013. And they even extended that deadline until June 11, 2013.

    I just passed on the Rate Limit information for people to be aware of.  On my main twitter account, I get rate limit Exceeded messages all the time, because I have 2 Android devices, and some other applications all authorized on that account. So with yet another Application (BrightSign Players) adding to the API Accesses, I would be seeing the Rate Limit Exceeded messages all the time.

    And yes, BrightAuthor should respect the users browser choice.

    John

  • 0
    Avatar
    Walter

    I'm aware of the history behind the auth changes, after having to deal with them as a web/app dev myself (before the cutoff date).

    What I'm referring to is the type of OAuth that is used in BA 3.7.0.13.  Twitter offers two types of authentication for their APIs -  https://dev.twitter.com/docs/auth  It looks like BA is using OAuth signed requests via the 3-legged authorization process, but it may be able to use "application-only" authentication, which wouldn't require the users to authenticate if I am reading the spec right.  Using this model the app itself is authorizing to Twitter, not through a user account, and not affecting the user's rate limit.  If rate limits are a problem for an application using "application-only" auth, then Twitter provides a process for being whitelisted.

     

    Walter @ p-egd

  • 0
    Avatar
    Lyndon

    John, can you send me one of your projects with the existing twitter feed that you can't get to work in  .13? Send it to support@brightsign.biz, please. 

    Walter, I forwarded your comments on authentication to the lead developer for BrightAuthor. 

  • 0
    Avatar
    JohnLBV

    BrightSign support already has a copy of the project that wouldn't display anything when updated to BA 3.7.0.13.

    It's the same project that I am still waiting to hear back from on the Media RSS cache files not deleting issue, with the exception of I removed the use of the custom Autorun (that was for the added lines that were supposed to fix the Media RSS cache issue).

    John

  • 0
    Avatar
    Alex

    John,

    BA3.7.0.13 is for twitter testing only. It's not a public version. Please use BA3.7.0.12 for the Media RSS test.

  • 0
    Avatar
    JohnLBV

    Wow! It's like the BrighSign Support Staff does not even bother reading any of these threads anymore?

    Yes, I know BA3.7.0.13 is not public, and for testing only, that is why one of you sent me the links to download.

    I tested it, and it didn't work, and  I was asked  to send a copy of the presentation that didn't work.

    I told you that Support already has that presentation, and that it was the same one that I had sent in recently in regards to another issue (so why send it again if you already have it).

    (Unrelated to this thread, I am no longer testing the Media RSS Cache Issue - I tested, my clients tested, and others tested the solution your staff offered, and it didn't work for anyone, we are all still waiting on BrightSign to respond with a working solution to that issue before trying any more testing).

    Yes, I know there are several Support Staff Members here, but please try and read what others are working on and posting in the forums. We are all here for help and to help each other, but it often seems like an uphill battle for the users.

    Thank you.

    John

     

  • 0
    Avatar
    GGL Corporation Ltd

    Have tried all of the abovementioned - twitter issues - cannot recognise tweet name.

    When will there be a fix for this issue >???????

  • 0
    Avatar
    Lyndon

    john, I opened your test project, then opened the twitter entry, and hit authenticate. After entering the login info for my twitter account, and publishing your project, I saw the reuters twitter feed on my display. One thing I wanted to verify if that you removed the custom autorun from the project before publishing. That autorun wouldn't work with a 3.7 brightauthor project. 

  • 0
    Avatar
    Lyndon

    Mark, did I send you a link to 3.7.0.13? That's the release that fixes the twitter issue. We're releasing 3.7.0.14 to beta tomorrow. 

  • 0
    Avatar
    GGL Corporation Ltd

    We have tested all solutions spoken of here and nothing is resolving the twitter issue. ??? This last comment form support - is this suggesting that there is no issue with twitter >???

     

     

  • 0
    Avatar
    GGL Corporation Ltd

    Hi John no we have not received at this point - could you please send thank you

  • 0
    Avatar
    Lyndon

    Mark, which brightsign do you have? I can send you a link to brightauthor and the firmware, both of which will be posted tomorrow. The only firmware not yet finished is for the HD210/HD1010. 

  • 0
    Avatar
    GGL Corporation Ltd

    We are running bright author  3.7.0.12  and latest firmware on HD1010W players.

    We have 08 units under test here.

  • 0
    Avatar
    Jorge Bermudez

    Hi, I´m working with HD1020 and XD1230, and have the same problem, Im ussing BA 3.7.0.14, could you hel me please!!!

  • 0
    Avatar
    GGL Corporation Ltd

    Can you please advise when you will have a fix for the HD1010W players ? 

  • 0
    Avatar
    Alex

    Jorge, please export the problem project (File - Export <presentation name>) to a folder on your PC, zip it and send to support@brightsign.biz for review.

  • 0
    Avatar
    JohnLBV

    OK - so as far as my issues, I have it working one way with BA 3.7.0.14 and 4.6.46 but I had to do the Project as a Local Storage setup.

    I have yet to get Simple File Networking (my normal workflow to players) to work with the BA 3.7.0.14 version  It seems too many things have changed as far as using Simple File Network with the new version, so you can't just install new firmware in the player, and upload the new Simple File Network files to the Server.  I even tried creating a new SD card with a new Setup fileset on it, and it still didn't work that way.  So I need to spend some more time to figure out what all has changed in the new version to get Simple File Networking to work

    John

  • 0
    Avatar
    Alex

    John,

    Please create new setup files for simple file networking and use this url https://dl.dropboxusercontent.com/u/106638061/SFNtest/

    It points to a 2-zone project (images + twitter) on my dropbox account. The project was created using BA 3.7.0.14 for HD1020 model. The unit should have 4.6.46 firmware version installed. The project is set to 1920x1080x60p.

    Please confirm if unit plays the twitter feeds.

  • 0
    Avatar
    GGL Corporation Ltd

    We are running bright author  3.7.0.12  and latest firmware on HD1010W players.

    We have 08 units under test here.

     

  • 0
    Avatar
    GGL Corporation Ltd

    Can you please advise when you will have a fix for the HD1010W players ? 

     

  • 0
    Avatar
    Alex

    Mark, when the firmware for HDxx10 series is ready, it will be posted on the software downloads page.

Please sign in to leave a comment.
Can't find what looking for? Try to
Powered by Zendesk