New Firmware and Software Versions Available

There are new versions of BrightSign firmware and BrightAuthor software available on the Software Downloads page. The firmware download section is located below the BrigthAuthor download section; scroll down the Software Downloads page to find what you need.

The following is a short summary of each update. For a more comprehensive list of new features, improvements, and bug fixes, please view the release notes, which are located on the Software Downloads page and contained in each download file.

Firmware Version 4.4.44

This firmware update is intended for the following BrightSign models:

  • XD230
  • XD1030
  • XD1230
  • HD120
  • HD220
  • HD1020

Note that the update files for XD and HD players are different. Make sure to use the download link that corresponds to your player model.

Both XD and HD updates enable new negative time-code events, which allow events to trigger from the end of a video clip (this feature is only available in BrightScript). 

The XD firmware update corrects issues with the CVBS (composite video) output through the VGA port. It also fixes a bug that caused HTML5 <video> elements that had looping parameters to not loop.

BrightAuthor Version 3.5.0.24

This version of BrightAuthor is a companion release with the above firmware, so it requires version 4.4.44 to be installed on the players listed above before you publish to them.

This update provides a fix for the Advanced Network Setup issue that we outlined in a previous post. Also, touch-screen events now work in HTML5 zones regardless of whether you check the Display Cursor option or not. 

Have more questions? Submit a request

10 Comments

  • 0
    Avatar
    JohnLBV

    Hello:

    I find that naming the XD and HD versions of the firmware with the exact same version number is confusing to many people.

    I am used to looking at the downloads page, and grabbing version 4.x firmware for the HD versions, and version 3.x firmware for the older models.  I know others that do the same.

    It might be better to utilize 5.x for the XD models to help with this?

    5.4.44

    4.4.44

    3.9.11 

    Or at least may I suggest adding "X" and "H" to the version numbers, to help avoid confusion, so that is it easier to visibly see the difference when quickly scanning the downloads page?

    X4.4.44

    H4.4.44

    I know you have XD and HD in the download file name, and in the text above each of the download files, but sometimes when you are in a hurry, old habits die hard, and  you just grab the first 4.x version you see.

    Thank you.

  • 0
    Avatar
    Lyndon

    I'll log a request to improve the downloads page so it's easier to tell what release is for which player

  • 0
    Avatar
    Alex Muñoz Basols

    Hey good ideas also a resume of all versions and a comparission in table format and compatibility. I could be very usefull. Thanks

  • 0
    Avatar
    Gaye Esguerra

    But where is 4.4.44? It's not in the Software Downloads link above.

  • 0
    Avatar
    JohnLBV

    Version 4.4.4 4 has been superseded by newer versions of the firmware.

    The software downloads area has the most current versions of the Firmware and BrightAuthor, and in most cased you should update to the most current version for both.

  • 0
    Avatar
    Peter Lau

    Does the TD1012 use the same firmware as the HD1010W?

  • 0
    Avatar
    JohnLBV

    Peter:

    According to this post, it uses the TD1012 uses the same firmware as the HD1010:

    http://support.brightsign.biz/entries/20445482-What-Software-Firmware-do-I-need-for-the-TD1012-

     

     

  • 0
    Avatar
    Alex Muñoz Basols

    Hello i have The td1012 latest working is 3.10.45 because latest versión 3.10.57 and 3.11.11 has a bug for hdmi output and its not working.

  • 0
    Avatar
    Peter Lau

    Thanks. I am now using the 3.10.45 firmware for the TD1012. The Nanosign website instructions make it very confusing as to what firmware/software that can be used.

  • 0
    Avatar
    Alex Muñoz Basols

    But for example mrss not works with 3.10.45 due a bug, you have to use 3.10.35 and 3.5.0.36, only this works :( :(

    also happens 3.10.42 and 3.10.57. I don't know when it's goinf to be fixed.

    B.R. 

Please sign in to leave a comment.
Can't find what looking for? Try to
Powered by Zendesk