How do I pause/resume a video in BrightAuthor?

You can attach Commands to events to pause and resume videos in a BrightAuthor presentation.

  1. Create an Interactive presentation with a video (example attached).
  2. Select the Events tab under Media Library and drag the desired event onto the video.
  3. In the Main tab of the event, choose Remain On Current State.
  4. In the Advanced tab, click Add Command and select Video from the dropdown list.
  5. Select Pause.
  6. Create a second event with the same configuration and choose Video - Resume

Sample Presentation - Touch & Gpio Events Control Pause/Resume

Note: The included project was created using BrightAuthor 3.7.0.39. The link includes sample images and a video.

Have more questions? Submit a request

33 Comments

  • 0
    Avatar
    Justin Hutchison

    How can I get this working with UDP?

     I followed your directions:

    1. Added a UDP Event
    2. Under** Advanced** I added the commands for Pause & Resume.

     My video will 'step' it just pauses for a millisecond then resumes.

    The sample you have on this page does not work with UDP commands

     

  • 0
    Avatar
    Nate Turley

    Does Pause/Resume work in the preview function of 3.8.0.30 Beta? 

    I tried it and it doesn't seem to work... I don't have hardware right now to confirm if it works on the XD1030

  • 0
    Avatar
    Lyndon

    Those commands should work but appear to be not working at the moment. 

  • 0
    Avatar
    Callie Holmes

    I can't get this to work in my interactive presentation, created in BrightAuthor 4.4.0.15. This is a multizone interactive presentation, and I've set up the touch events just as it says in these instructions (and in the example presentation). Do you have any idea what I could try or what might be going wrong? Ideally, I'd like to have identical touch regions, but the first time it's touched I want the video to pause and the second time I'd like the video to resume.

  • 0
    Avatar
    Lyndon

    Can you send us a copy of the presentation? Send it to support. or, post a link to the presentation here. We only need the presentaion, not the content.

  • 0
    Avatar
    Callie Holmes

    https://drive.google.com/file/d/0B8txNB4jzA-CNmZVRjVsQm01Y1E/view?usp=sharing (FYI I have it's a touchscreen and ideally I'd like the first touch of the video to pause it, and the second touch to resume it.) Thank you!

  • 0
    Avatar
    Lyndon

     

    I added a variable called "paused" with a default value of "no".

    Under the touch event, I went to advanced, and conditional targets.

    If paused was no (default), under advanced, I sent a video pause command, and I set the variable to yes.

     

    if pause was yes, under advanced, I sent a video resume command, and I reset variable (back to its default value)

     

    This allows me to use the same touch to do both functions. Your modified project's here

     

    https://www.brightsignnetwork.com/download/customers/Economy_templatedesign_round2.bpf

     

     

     

     

     

     

  • 0
    Avatar
    Lyndon

    Just noticed an error in my images. The target state should not be an image, but current state only. I've updated the project file. 

    Edited by Lyndon
  • 0
    Avatar
    Callie Holmes

    Thanks so much for the response. I get the logic behind the steps you gave, but I'm still having problems getting the pause/resume function to actually work. The updated project that you posted that I was able to download still had the target state set as an image. I changed all of those to current state, but nothing is happening when I click on the video to pause/resume. (In case it matters, I am using the preview function on my PC to test this, haven't actually put the published project on the BrightSign player yet--should that make a difference?). Here's the version of the project you made that I'm working with (with the modified target states): https://drive.google.com/file/d/0B8txNB4jzA-COGdSSWFPcmRFVEk/view?usp=sharing  Any idea why the pause/resume isn't working?

  • 0
    Avatar
    Callie Holmes

    FYI --  I decided to try the project on the BrightSign player to see if it behaved differently, and it worked! Pause/resume still doesn't work when I preview through BrightAuthor, but it does work in the "real world." Thank you!!!

  • 1
    Avatar
    Brecht Gettemans

    I'm trying to do the same thing (pauze/resume) with one GPIO button. I downloaded the project but when I click the event there's nothing to see in the conditional targets. I tried to do as much as you do but ofcourse I must have something wrong because nothing happens.

    Is this ok:

    And do I need to do something here:

    The conditional targets are set as shown in the pictures above.

     

    Thanks!!

  • -1
    Avatar
    HawFar

    Hello,

    I am using an XD 3211 device. I have a 5 minute long MAIN video in my presentation. While the MAIN video is playing i want to put a 30 second video as a "break" (using my BP900 button panel). 

    I am fine with jumping from the MAIN video to the "break" video. The problem is that every single  time the "break" video ends and jumps back to the MAIN video, the MAIN video starts from the beginning. 

    Could you please show me some ways to continue my MAIN video from the same frame i jumped to the "break" video?

    Thank you

  • 0
    Avatar
    Lyndon

     

    The attached example will do what you want.

     

    This is an involved project. There's a plugin that's used to seek to the last position when you return to the main video. 

     

    when the main video is playing a timer is running every 10th of  second that keeps track of position. A playtime variable is updated with this counter. 

     

    When you push a button to play another video, that counter is stopped. 

    When you return to the main video, the plugin is used to go to that position in the video and the counter is restarted.

     

    When the main video ends, the counter variable is reset to zero. 

     

    https://www.brightsignnetwork.com/download/Tools/Pause_ResumeFromLastPosition_bp900.zip

     

    I would open this project and not delete anything. You can double click on each video in the project, and browse and choose a new video to replace it with, leaving all the settings intact. 

  • 0
    Avatar
    HawFar

    Hi again,

    that was exactly what i was looking for. Thank you very much. 

    Made my day !

  • 0
    Avatar
    HawFar

    Hello,

    i got the presentation work when the main video is 5 mins or below 5 mins. Is it possible to change the limitation of the main video? because every time the "break" video jumps back to the main video (8 mins) it shows me the first frame of the main video then starts again from the same frame the "break" video was started.

  • 0
    Avatar
    syed

    I need to turn off my tv using rs232.... My tv support 3.5mm jack for rs232 my brightsign is xd233 i need to use button 0... Please tell me how do I connect the wiring , which are the port i need to connect , i have the supported Phoenix connector ...which are the cable for connect to jack's sleeve, ring ,and tip.... i know sleeve is in pin1 .... My doubt on 3.3v and the button.... Please tell me as soon as possible

  • 0
    Avatar
    Lyndon

    It sounds like you're asking about gpio and rs232.  are you trying to create a serial port using the phoenix port?

    gpio pin 3 is receive, and gpio pin 11 is the send.  If you wired up that port, you'll also need a plugin to use the alternative serial port. I have a plugin that uses that port. The serial port will show up as serial port 1.

     

    The pugin name is "altserial". 

    https://www.brightsignnetwork.com/download/Scripts/altserial_pins3and11_plugin2.brs

     

     

     

  • 0
    Avatar
    Miguel Maqueda
    Hello, my case is the same as i mention
    HawFar on June 12, 2018 1:57 PM.
    I have downloaded the Lyndon solution 
    (https://www.brightsignnetwork.com/download/Tools/Pause_ResumeFromLastPosition_bp900.zip),
    but it does not work properly. At the end of video2, the main video is played from
    the beginning. regards
  • 0
    Avatar
    Lyndon

     

    Please clarify what's not working. So the resume works until one of the videos finishes?

  • 0
    Avatar
    Miguel Maqueda
    lo siento, he estado indispuesto por unos días.

    First of all say that I replaced the GPIO button with a timer,
    with the same advanced properties, to return to the first video.
    El problema es que cuando se reanuda el primer video lo hace desde el principio

    y no desde el punto donde se detuvo. Saludos
    Edited by Miguel Maqueda
  • 0
    Avatar
    Morten Lindegaard

    @Lyndon - or anyone with enough insight

    I am hoping you could help me regarding your solution https://www.brightsignnetwork.com/download/Tools/Pause_ResumeFromLastPosition_bp900.zip

    This would be the perfect solution for me - if I could get it working!! So far I have the same problem that @Miguel Maqueda describes. I publish the downloaded version (thru BA 4.7.2.18 onto a XD1033 (firmware 6.2.63.2)) and the only change I've made is adding a Keyboard event with the same settings as the BP900A-event (same start state, Transition to new state, Advanced::Send::SendZoneMessage::stoptimer).

    Video starts, I wait a few seconds (until DSE-logo is gone), press my keyboard, 2.mp4 plays through and then ImGonnaMakeitBetter.mp4 restarts (DSE-logo reappears). So the resume-funcion isn't doing what it is supposed to do (on my set-up anyway).

    What are the odds that something clever could be done?

     

    And many, many thanks in advance!

  • 0
    Avatar
    Morten Lindegaard

    BTW. I'm wondering. If I'm reading this correctly - everytime the main video is called the counter/plug-in is reset. Shouldn't there be a condition perhaps; if timer is NOT = 0 then play from timer-count... or some logic like that?

  • 0
    Avatar
    Lyndon

     

    No. 

    Every time you enter the video, it pauses, sends the seek command which uses variable value to know where to go.

    It then pauses again, starts the timer, and then resumes. 

     

    The variable is only reset when you publish for the first time, or when the media end is seen from the main video. 

     

  • 0
    Avatar
    Lyndon

    Ok, so I did a udp version, and it works fine on my end. Can you send a copy of your keyboard version that's not working?  Same as original with project file that includes udp as well. 

    https://www.brightsignnetwork.com/download/Tools/Play_Pause_ResumeFromLastPOsition-46test-2videos-incl-udp.zip

     

    They only thing I added under advanced for my udp event was the send zone message with stop timer..

     

  • 0
    Avatar
    Morten Lindegaard

    Thanks Lyndon.

    I think this perhaps explains something. I can duplicate your [UDP Input Event] settings (as shown in image above) but if I add a [Keyboard Input] instead  i do not get the same dialogue ("Asign input to variable" etc. is not there). Same goes for when I open Advanced settings for the original [BP900A Event] that you made.

    I am not at my office and cannot test this before tomorrow - but if the UDP-version works I'll be really happy.

    The only reason I added the keyboard input was to be able to test with only one BrightSign at a time. UDP is the way I need to go for my project. But I'm still very curious to know if it could be done with Keyboard Input.

    This is what your BP900A looks like in my BrightAuthor

    And this is my Keyboard Input. No dialogue at the button to call "PlayTime"

  • 0
    Avatar
    Lyndon

     

    The assign input option is only available on serial and udp. It's not in use in that screenshot.

    Please send a link to you project file. It looks right. I just connected a keyboard to my xt player, and my video resumes where it left off. 

     

    Please also send a copy of the system log from your player, the log tab. This will tell us if the plugin is running when it fails to work for you. In order to see if the plugin is running from the log tab, make sure when you publish, that debugging to the system log is enabled from the publish tab. 

     

     

  • 0
    Avatar
    Morten Lindegaard

    Oh,Wow! Outstanding.

    Let me try this in the morning (I'm back at office in about and hopefully working with BrightSigns in perhaps 14 hours or so)

    At first I think maybe your answer is very promising as I haven't tested the serial. Perhaps UDP is 'all it takes'.

    I suppose the log will be written on the sd-card (and perhaps named understandably?) or do I need to browser-log-on the unit to get the log? If I cannot find it I'll ask again :-)

  • 0
    Avatar
    Lyndon

    The system log isn't written to the sd card by default. So, if you can, log into the player's ip address. You shouldn't need udp in your project. I just tested it first because it was simplest for me.

     

  • 0
    Avatar
    Morten Lindegaard

    I have too many days where research time is impossible.

    I only got this far:

    Downloaded your https://www.brightsignnetwork.com/download/Tools/Play_Pause_ResumeFromLastPOsition-46test-2videos-incl-udp.zip and published it to one BrightSign (slave). Added a pause+resume keyboard event on the same file, saved that as ´master. Changed the Presentation Properties::Interactive::UDP to 'All devices connected via Ethernet' instead of single IP (as I new more players responding later on). Published 'master' to another BrightSign.
    My Keyboard events on master should pause /resume video locally and send the UDP-'go'-command you added to the 'slave'. But 'slave' doesn't respond. I probably missed some thing somewhere - but didn't get the time to fiddle with it.

    Now, back at home, I have some logs from the SD-cards. So I'd like to try your patience and send master+slave bpf's and the logs I can find  - but I can only attach images in this dialogue. How can I send you the files?

    BTW: earlier in the thread @HawFar wrote that he couldn't get videos longer than 5 minutes to work. Is that a solved issue? I am hoping to be able to run a 120 minute video - with added pauses/resmues.

    Best wishes and high hopes

    Edited by Morten Lindegaard
  • 0
    Avatar
    Lyndon

     

    I'll test a longer video and see if I have any issues. You can send your files to support at brightsign.biz. 

    Ok, so you're using two of these projects together then. One project file to send messages to a slave project file?

Please sign in to leave a comment.
Can't find what you're looking for? Try to
Powered by Zendesk