0

XT1143 Media Server Streaming HDMI Input

Hi,

I have around 10  XT1143 units and I need to stream the HDMI Input from one of them to the other 9 over TCP/IP using RTSP.

How do I go about doing this ?.

As I understand  I need to setup one to act as a media server and load a script to start an RTSP media server:

s = CreateObject("roMediaServer")
s.Start("rtsp:port=554")

And on the players I need to do something like this:

rtsp://IP_address:port/hdmi:,encoder:

 

Is this all the code that I need to run my setup or am I missing something ?.

If not can you please provide me with a script to do it.

Thanks.

 

34 comments

  • 1
    Avatar
    Lyndon

    I've attached links to two plugins. In each case, the server player starts serving immediately. I've included readme's that show sample urls that you'd use in vlc or on another brightsign to playback content from the server. 

     

    You can't play hdmi input on the server using this plugin. But, you can serve audio.

    https://www.brightsignnetwork.com/download/Tools/StreamingServer_HdmiInput.zip

     

    There's no audio when serving the display. In this example, you'd set the server to play hdmi input, and then server what's on that unit's display. 

    https://www.brightsignnetwork.com/download/Tools/server_plugin_display.zip

     

  • 0
    Avatar
    Dwight Burgos

    The files in the first link worked great for what I was doing!  Thanks BrightSign Support!!!!

     

    Thank you,

    Dwight

  • 0
    Avatar
    Nathan Beranger

    Hello,

    I think I must be missing something because I have not been able to get this to work. When I try to connect from VLC it tells me the connection failed and the input can't be opened. When I check the logs in VLC, it appears that it is connecting but is not finding anything to actually stream. I can see on my display that is connected to the XT1143 "Streaming HDMI Server".

    I made sure to add the script plugin. Was there anything else I had to do with your script to get this working?

     

    Thanks,
    Nathan

  • 0
    Avatar
    FP

    Make sure that you are formatting the URL properly on your VLC player.

    That's an example below, replace the ip address with your Brightsign unit ip (the one that is running the script) and check that the port is correct for your unit. Other than that it should work.

    rtsp://192.168.1.10:8090/mem:/hdmi/stream.ts

  • 0
    Avatar
    Nathan Beranger

    Thanks. I've confirmed that the port is open and I've entered my IP (which I know works because I can access the web console when I plug it into a browser), but I am not able to connect from VLC.

  • 0
    Avatar
    FP

    What type of content are you trying to stream ? Exact video source.

  • 0
    Avatar
    Nathan Beranger

    I am using the Live Video widget and have a laptop connected via HDMI to the input of the XT1143.

     

    Here is what is showing in my VLC log when I try to connect:

    ore debug: adding item `rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts' ( rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts )

    core debug: meta ok for (null), need to fetch art

    core debug: processing request item: rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts, node: Playlist, skip: 0

    core debug: rebuilding array of current - root Playlist

    core debug: looking for meta fetcher module matching "any": 1 candidates

    core debug: rebuild done - 1 items, index 0

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/fetcher

    core debug: starting playback of the new playlist item

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher

    core debug: resyncing on rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts is at 0

    core debug: creating new input thread

    core debug: Creating an input for 'rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts'

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher/tvrage.luac

    core debug: requesting art for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: using timeshift granularity of 50 MiB, in path '/tmp'

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher/tvrage.luac

    core debug: looking for meta fetcher module matching "any": 1 candidates

    core debug: `rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts' gives access `rtsp' demux `' path `10.0.150.133:8090/mem:/hdmi/stream.ts'

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/fetcher

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/fetcher

    core debug: specified demux `any'

    core debug: no meta fetcher modules matched

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher

    core debug: creating demux: access='rtsp' demux='any' location='10.0.150.133:8090/mem:/hdmi/stream.ts' file='(null)'

    core debug: searching art for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: looking for access_demux module matching "rtsp": 14 candidates

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher/tvrage.luac

    core debug: looking for art finder module matching "any": 2 candidates

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher/tvrage.luac

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/fetcher

    core debug: no meta fetcher modules matched

    core debug: searching art for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: looking for art finder module matching "any": 2 candidates

    live555 debug: version 2016.02.22

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/art

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/art

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/art

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/art

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/00_musicbrainz.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/00_musicbrainz.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/00_musicbrainz.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/01_googleimage.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/00_musicbrainz.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/01_googleimage.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/01_googleimage.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/02_frenchtv.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/01_googleimage.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/02_frenchtv.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/02_frenchtv.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/03_lastfm.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/02_frenchtv.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/03_lastfm.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/03_lastfm.luac

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/art

    core debug: no art finder modules matched

    core debug: art not found for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/03_lastfm.luac

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/art

    core debug: no art finder modules matched

    core debug: art not found for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    live555 debug: RTP subsession 'video/MP2T'

    live555 debug: setup start: 0.000000 stop:0.000000

    core debug: creating demux: access='' demux='ts' location='' file='(null)'

    live555 debug: We have a timeout of 60 seconds

    live555 debug: spawned timeout thread

    live555 debug: play start: 0.000000 stop:0.000000

    core debug: using access_demux module "live555"

    core debug: looking for meta reader module matching "any": 2 candidates

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/reader

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/reader

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/reader/filename.luac

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/reader

    core debug: no meta reader modules matched

    core debug: `rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts' successfully opened

    macosx debug: Enable media key support

    macosx debug: prevented sleep through IOKit (34115)

    macosx warning: variable stereo-mode doesn't exist or isn't handled

    macosx warning: variable stereo-mode doesn't exist or isn't handled

    macosx warning: variable stereo-mode doesn't exist or isn't handled

    live555 warning: no data received in 10s. Switching to TCP

    core debug: looking for demux module matching "ts": 66 candidates

    core debug: no demux modules matched

    live555 debug: RTP subsession 'video/MP2T'

    live555 error: SETUP of'video/MP2T' failed liveMedia4

    live555 debug: setup start: 0.000000 stop:0.000000

    live555 error: Nothing to play for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    live555 error: TCP rollover failed, aborting

    core debug: EOF reached

    core debug: removing module "live555"

    core debug: finished input

    macosx debug: releasing sleep blocker (34115)

    core debug: dead input

    core debug: changing item without a request (current 0/1)

    core debug: nothing to play

  • 0
    Avatar
    FP

    Did you download the zip file from the second link ?

    double click : StreamingServerDisplay-4415

    select the script once it prompts you : server_plugin_display

    and then publish.

     Sorry if it sounds dumb but I am just trying to follow the steps that you took for this

  • 0
    Avatar
    Nathan Beranger

    I was actually using the other plugin, server_plugin_hdmi. I just tried switching to server_plugin_display and still was not able to connect. Here is the VLC log from that attempt:

    core debug: adding item `rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts' ( rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts )

    core debug: meta ok for (null), need to fetch art

    core debug: processing request item: rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts, node: Playlist, skip: 0

    core debug: rebuilding array of current - root Playlist

    core debug: rebuild done - 1 items, index 0

    core debug: starting playback of the new playlist item

    core debug: resyncing on rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts is at 0

    core debug: creating new input thread

    core debug: looking for meta fetcher module matching "any": 1 candidates

    core debug: Creating an input for 'rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts'

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/fetcher

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher/tvrage.luac

    core debug: requesting art for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: using timeshift granularity of 50 MiB, in path '/tmp'

    core debug: looking for meta fetcher module matching "any": 1 candidates

    core debug: `rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts' gives access `rtsp' demux `' path `10.0.150.133:8090/mem:/hdmi/stream.ts'

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/fetcher

    core debug: specified demux `any'

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher/tvrage.luac

    core debug: creating demux: access='rtsp' demux='any' location='10.0.150.133:8090/mem:/hdmi/stream.ts' file='(null)'

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher/tvrage.luac

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/fetcher

    core debug: looking for access_demux module matching "rtsp": 14 candidates

    core debug: no meta fetcher modules matched

    core debug: searching art for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: looking for art finder module matching "any": 2 candidates

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/fetcher/tvrage.luac

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/fetcher

    core debug: no meta fetcher modules matched

    core debug: searching art for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: looking for art finder module matching "any": 2 candidates

    live555 debug: version 2016.02.22

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/art

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/art

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/art

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/art

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/00_musicbrainz.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/00_musicbrainz.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/00_musicbrainz.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/00_musicbrainz.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/01_googleimage.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/01_googleimage.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/01_googleimage.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/01_googleimage.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/02_frenchtv.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/02_frenchtv.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/02_frenchtv.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/02_frenchtv.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/03_lastfm.luac

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/03_lastfm.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/03_lastfm.luac

    lua debug: skipping script (unmatched scope) /Applications/VLC.app/Contents/MacOS/share/lua/meta/art/03_lastfm.luac

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/art

    core debug: no art finder modules matched

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/art

    core debug: art not found for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    core debug: no art finder modules matched

    core debug: art not found for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    live555 debug: RTP subsession 'video/MP2T'

    live555 debug: setup start: 0.000000 stop:0.000000

    core debug: creating demux: access='' demux='ts' location='' file='(null)'

    live555 debug: We have a timeout of 60 seconds

    live555 debug: spawned timeout thread

    live555 debug: play start: 0.000000 stop:0.000000

    core debug: using access_demux module "live555"

    core debug: looking for meta reader module matching "any": 2 candidates

    lua debug: Trying Lua scripts in /Users/nberanger/Library/Application Support/org.videolan.vlc/lua/meta/reader

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/meta/reader

    lua debug: Trying Lua playlist script /Applications/VLC.app/Contents/MacOS/share/lua/meta/reader/filename.luac

    lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/meta/reader

    core debug: no meta reader modules matched

    core debug: `rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts' successfully opened

    macosx debug: Enable media key support

    macosx debug: prevented sleep through IOKit (34236)

    macosx warning: variable stereo-mode doesn't exist or isn't handled

    live555 warning: no data received in 10s. Switching to TCP

    core debug: looking for demux module matching "ts": 66 candidates

    core debug: no demux modules matched

    live555 debug: RTP subsession 'video/MP2T'

    live555 error: SETUP of'video/MP2T' failed liveMedia4

    live555 debug: setup start: 0.000000 stop:0.000000

    live555 error: Nothing to play for rtsp://10.0.150.133:8090/mem:/hdmi/stream.ts

    live555 error: TCP rollover failed, aborting

    core debug: EOF reached

    core debug: removing module "live555"

    core debug: finished input

    macosx debug: releasing sleep blocker (34236)

    core debug: dead input

    core debug: changing item without a request (current 0/1)

    core debug: nothing to play

  • 0
    Avatar
    FP

    Sorry, Yes you should use the first link not the second.

    What is your network setup? between your brightsign unit to your computer running VLC ? what are all the devices in between ?

    You could have some device blocking your traffic.

     

  • 0
    Avatar
    Nathan Beranger

    We are on a GPON network and currently our BrightSign boxes are on a separate VLAN.

    That being said, I've confirmed with our network specialists and there is nothing blocking access. In fact, if you look at the VLC log you can see it finding the IP address... it just can't find anything to actually play.

  • 0
    Avatar
    FP

    I will say get yourself a cheap router and setup a small network

    hdmi source  --> brightsign --> router --> pc runnning vlc

    with no firewall rules and no vlans.

    If this works then chat with your IT department and show them that what you are trying to do works (so they don't complain =)  )

    You may want to run Wireshark on your small setup to dissect the network traffic coming of your brightsign, then you will have the exact protocols that you are trying to send over the network.

    Good luck!.

  • 0
    Avatar
    Nathan Beranger

    My network team insists that our current setup functions the exact same way as if my computer was connected to the exact same switch as the BrightSign. As I've pointed out, I also have no problem connecting to it through the web client, BrightAuthor, and ping. It even appears that VLC can see the XT1143, it just can't find any video to play.

     

    Is there anything on the XT1143 that I can view to confirm that it is indeed functioning as a streaming server?

  • 0
    Avatar
    FP

    A couple of things that could affect your setup.

    network traffic ( UDP ) getting blocked somewhere in your network setup.

    You are running VLC on vmware or other virtualization software.

     

    As a basic troubleshooting step regardless of what the IT department says. You need to minimize the points of failure.

    and a complex network setup is one of them. Something else that you can try if you are running VLC on a mac is a PC.

     

     

  • 0
    Avatar
    Nathan Beranger

    I understand what you are saying about that network, but we are 99.999% certain it is not a network issue.

     

    Is there anyway for me to confirm that the BrightSign unit is actually streaming the live feed it is getting form the laptop we have connected to the HDMI input?

  • 0
    Avatar
    FP

    Use wireshark and apply a filter to check for traffic on the port that the brightsign is streaming

    Your brightsign unit is streaming on port 8090 and i believe is sending it over utp

    The filters below are for both tcp and udp. Check both of them to see what kind of traffic flowing on them.

    Also make sure that it is coming from the brightsign ip address

    tcp.port == 8090
    udp.port == 8090
  • 0
    Avatar
    Lyndon

    In the master player's log, the script says it's running? You should republish from brightauthor, and on the publish tab, make sure the system level debug is enabled. This will put output from brightauthor's playback into the system log. Right now your's is just firmware messages.

     

    If the plugin's not running, there should be an error early after the republish or reboot indicating that the plugin is invalid.

     

     

  • 0
    Avatar
    Nathan Beranger

    Thanks Lyndon.

    I already had that box ticked off but I just unticked, reticked, and published again. I am not seeing anything different showing up in the log though, assuming I should be reading the log at http://10.0.150.133/log.html ?

    Are there any detailed step by step instructions on getting this up and running? It might help us determine where the problem lies.

  • 0
    Avatar
    Lyndon

    You should go to the control tab and reboot the player..

    No, there's no speicial setup. You should just publish it, and the plugin you're using should turn it on automatically. That's it... Can you post the bpf file and plugin, or send it to support..

     

  • 0
    Avatar
    Nathan Beranger

    Hi Lyndon. 100% I can send along the BPF and BRS files. Can you let me know what address I should be sending them to exactly? There doesn't appear to be any way to attach them to this post.

  • 0
    Avatar
    Lyndon

    send it to support @ brightsign.biz. I'll publish the same plugin and project to one of my units and see if it fails to start the server. I'll try playback in vlc. I can post an image from vlc if it connects as expected..

     

  • 0
    Avatar
    Nathan Beranger

    Here is one more question... is it possible to stream from the XT1143 and at the same time have it displaying that same live feed on the display it is connected to?

  • 0
    Avatar
    Lyndon

    If you were streaming the display, then yes, but you don't get audio when streaming the display. But, streaming the display means you get to watch what's being served to other devices. 

  • 0
    Avatar
    Lyndon

     

    I sent a project example back to you. You had live video in the project itself. You can't stream live video and play live video. I put something else in the project file.


    as I said above, if you set the plugin to server display, then anything on the display is served, but not with audio. I believe there's a feature request logged to be able to stream audio. 

  • 0
    Avatar
    Dennis

    Hi Lyndon I got the same issue with Nathan with regards to the XT1143 is there any possibilities that can you also send me the file that you have send to him.

    Appreciate it so much..

    Thanks

  • 0
    Avatar
    Lyndon

     

    This one will serve the display:

    https://www.brightsignnetwork.com/download/Tools/server_plugin_display.zip

     

    This one doesn't allow you to play live video on the server, but serves the hdmi input. 

    https://www.brightsignnetwork.com/download/Tools/StreamingServer_HdmiInput.zip

     

  • 0
    Avatar
    Dennis

    Hi Lyndon,

    Still I'm having some problems with streaming the HDMI Input. With regards streaming the content of the brightsign such as videos or photos I don't have any issues the only problem is I can't stream the HDMI Input itself. Quick question also does the XT1143 has limitation on the input resolution since I'm sending 1080p60.

  • 0
    Avatar
    Dennis

    Hi Lyndon

    I'm getting this log from XT1143:

    [ 47.499] MediaStreamer::SetPipeline called with memsimple:/hdmi/stream.ts,rtpsimple://192.168.0.10:61786/?maxbitrate=90000

    [ 47.499] DestinationSimple::Connect: no such source /hdmi/stream.ts
    [ 47.500] DestinationSimple::Connect: no such source /hdmi/stream.ts

     

    This is my enabled plugin below:

     

    Function newserver(msgPort As Object, userVariables As Object, bsp as Object) print "newserver" s = {} s.version = 1.22

    'only 1 streaming option below can be set to start automatically

    s.streamdisplayenabled = false 'stream display output automatically

    s.hdmioutenabled = false 'stream hdmi output automatically

    s.hdmimultienabled = true 'stream hdmi output automatically to multicast

     

    -----

    Do you think I'm missing something on it?

  • 0
    Avatar
    Dennis

    Hi just want to ask a quick one do you have any tweak for me to stream my live input w/ audio on another brightsign? I have an XT1143 & XD230.

     

    Thanks..

  • 0
    Avatar
    Carlos Ferreira

    Hi Nathan,  Did you managed to get the XT1143 streaming like you wanted to?

     

    Thanks, Carlos

Please sign in to leave a comment.