0

Black screen with MRRS

What am I doing wrong here? 
 
I have a MRSS data feed works in the BrightAuthor preview but not the build on the Brightsign player, which gives me a black screen. The data feed is being pulled from the sample url https://brightsignnetwork.com/download/MRSS/Media_RSS_Image_Template. The project is a just has the Media RSS feed zone, with a data feed for both mrss and .  I've also done a factory reset prior to setting up the project, and tested all the equipment with a simple BrightAuthor project, which works. 
 
I have the Brightsign player setup for local network publishing, and I can access the diagnostic web server. I've run the Network Diagnostics, which have come up with everything connected, been able to ping my server computer and connect to an external website. I'm currently using an XD1230, running on firmware 6.1.76, and publishing from Bright Author 4.6.0.5. 
 
Thank you for your time 
 

15 comments

  • 0
    Avatar
    ^UD\_$

    The URL that you are using may be the cause for this issue.

    https://brightsignnetwork.com/download/MRSS/Media_RSS_Image_Template

     

    I'm not able to see the feed using a web browser. Can you?

    Best if you create a Live Media Feed in BSN, or use something like CNN RSS feed.

     

  • 0
    Avatar
    Philip O

    No, I cannot see the feed, but the file still works with my MRSS on the editor.

    As a test I created a ticker zone for RSS feed using the following CNN url:

    http://rss.cnn.com/rss/cnn_topstories.rss

    The same issue occurs, it works out fine in the Editor, but on the player all I get is a black screen.

  • 0
    Avatar
    ^UD\_$

    The BrightAuthor preview may not be helpful in this case.

    Can you share the project file through dropbox?

  • 0
    Avatar
    Philip O

    Here is the project .bpf with some of the assets, is there anything else I would need?

    https://www.dropbox.com/s/klg1hb74g84y5rq/DynamicPlaylist.zip?dl=0

    Edit: I've removed the extra data feeds but still getting the same result 

  • 0
    Avatar
    ^UD\_$

    I noticed that you are forcing resolution 1920x1080x60p

    Does your monitor support 60p?

    Try to uncheck the force resolution.

    Also, try to change the background color to something other than black, so you'll be able to tell that the display is showing the player's signal.

    Temporarily, remove all feeds other than the one that you are actually trying to show.

    You can save the presentation under a different name, before you remove the feeds, should you want to keep them for later.

     

  • 0
    Avatar
    Philip O

    Yes,the monitor does support 60p. 

    I've unchecked forced resolution, changed the background display color, and as I've said above, removed all extra data feeds. 

    Could the issue be with my XD1230 player, or some hardware issue?

  • 0
    Avatar
    ^UD\_$

    Are you seeing the new background color on the screen?

    Also, please verify that you are using the HDMI Out port on the XD1230, as it has two HDMI ports :) 

  • 0
    Avatar
    Philip O

    Yes I am seeing the new background color, and a non-interactive playlist which I put in for test purposes. 

    Also I double checked the HDMI is pulled into the out port.

  • 0
    Avatar
    ^UD\_$

    What about network settings? (IP, Subnet mask, DNS, Default gateway)

    Are you using DHCP?

    Try setting up an HTML5 state and point it at any site like google.com, to verify that the player can access the internet.

  • 0
    Avatar
    Philip O

    I've setup an HTML 5 state pointing a website, and the player can access the internet. 

    I can access the diagnostic web server, which I've run the Network Diagnostics through and it has come out with no issues in establishing a connection to the internet

    I'm not using DHCP, due to how our internet is setup in the office. I have the IP, Subnet mask, and Default gateway set to static but not the DNS. 

    Edit: I've set the DNS, after finding the number through the ipconfig command using command prompt. It still yields the same result

  • 0
    Avatar
    Lyndon

    can you send support the presentation so we can test? If you can log into the player when it's on the local network, go to the sd tab, to currentlog folder, and send us that log as well? Please send to support  @ brightsign.biz.

  • 0
    Avatar
    Mat Vano

    Hi

    Was this ever cleared out? I'm having the same issue, feed is validated but when I export to the player, it doesn't
    output anything. Changed the background to green (which is displayed) and did a network diagnostics check.
    All are ok but still no media being shown.

    FYI: I made the xml file with the MRSS generator from this forum.

  • 0
    Avatar
    Lyndon

    there's no errors in the diagnostic log in the currentlog folder indicating a problem with the content in the feed? and you are playing the mrss feed in the mrss widget, or are you using the playfile or imagelist widget?

  • 0
    Avatar
    Mat Vano

    I can't seem to get hold of the right files. Where is the currentlog folder located? I enabled logging and diagnostic web server in the
    setup tool and let the BrightSign run the setup. I can't find the above folder on the SD-card after a reboot with the brightsign project.

    When I log into the BrightSign over network, the Log-tab only gives me one big text file and no folder structure.

    I'm using the mrss widget to play the video file

  • 0
    Avatar
    Brandon

    @Mat - please submit a support ticket and include an export of your presentation.  Also keep in mind that most websites redirect to HTTPS these days, which means the player's clock must be set, otherwise the HTTPS negotiation will fail.

    _________________________________________________________________________

    Friendly reminder, the community forum is intended for user-to-user discussion.  It is not regularly monitored. For troubleshooting problems and to ensure a timely answer from a BrightSign representative, please submit a support ticket.

Please sign in to leave a comment.