0

HTML5 doesn't show up on display.

Hi. This is a little different from what is on the forums.

I am presenting a html 'feed?', application? to an XD1132 in landscape mode.  firmware v6.2.94 BrightAuthor v4.6.0.18.

When I preview the project in BA, it shows up correctly. When I publish it to the 1132, all I get is the device setup color on the screen. No HTML site.  If I then do a factory reset on the unit from the web interface (leaving the USB stick in the unit), when the unit comes back  up, it does in fact display the html app (although it is showing in portrait mode and the networking has been reset).

There are no Flash components in the web app (or so I am told).

Any idea why I cannot display this on a device which has been set up?

The setup is the default with static wired networking set up, the diag webserver with credentials turned on, Networked with local fileserver enabled, all logging turned on and a screen color chosen.

Here is the html I am passing to it through a local file on my computer which is set up as an HTML site in BA.

<html>
<head></head>
<body>
<iframe img src="http://vnt517:9001/App/Ops/ui/SignInTerminal/Task/SignInTerminal/Main?kioskStation=Kiosk-01" height="1100" width="1800" frameborder="0" scrolling="no">
#document
<html>
<head>
<meta name="viewport" content="width=device-width, minimum-scale=0.1"><title>Sign in Terminal</title>
</head>
<body style="margin: 0px;"><img style="-webkit-user-select: none;" src="http://vnt517:9001/App/Ops/ui/SignInTerminal/Task/SignInTerminal/Main?kioskStation=Kiosk-01">
</body>
</html>
</iframe>
</body>
</html>

 

 

The errors from the log are below.

[   31.037] *** 00:00:00.006 BCHP_PWR:
[   31.042] *** 00:00:00.011 nexus_platform: lynx B0 16.1, boxmode 1, product 7434 B0
[   31.067] *** 00:00:00.037 BHSM: BSP Platform[3.0.0] BSECK[0.0.0] modes[0x00]
[   31.084] *** 00:00:00.053 bdsp_raaga_img: DDP decoding is not supported
[   31.141] *** 00:00:00.111 nexus_picture_decoder: FW download not used
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/firmware/fp2011/bdsp_raaga_img.c:1428
[   31.231] ### 00:00:00.200 bdsp_raaga_fw_algo: Error in Opening the Image Interface for FW_ID =24
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/bdsp_raaga_fw_algo.c:5729
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/firmware/fp2011/bdsp_raaga_img.c:1428
[   31.231] ### 00:00:00.200 bdsp_raaga_fw_algo: Error in Opening the Image Interface for FW_ID =25
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/bdsp_raaga_fw_algo.c:5729
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/firmware/fp2011/bdsp_raaga_img.c:1428
[   31.231] ### 00:00:00.200 bdsp_raaga_fw_algo: Error in Opening the Image Interface for FW_ID =26
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/bdsp_raaga_fw_algo.c:5729
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/firmware/fp2011/bdsp_raaga_img.c:1428
[   31.231] ### 00:00:00.200 bdsp_raaga_fw_algo: Error in Opening the Image Interface for FW_ID =24
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/bdsp_raaga_fw_algo.c:5729
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/firmware/fp2011/bdsp_raaga_img.c:1428
[   31.231] ### 00:00:00.200 bdsp_raaga_fw_algo: Error in Opening the Image Interface for FW_ID =25
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/bdsp_raaga_fw_algo.c:5729
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/firmware/fp2011/bdsp_raaga_img.c:1428
[   31.231] ### 00:00:00.200 bdsp_raaga_fw_algo: Error in Opening the Image Interface for FW_ID =26
[   31.231] !!!Error BERR_INVALID_PARAMETER(0x2) at magnum/basemodules/dsp/src/raaga/bdsp_raaga_fw_algo.c:5729
[   31.469] *** 00:00:00.438 BXVD: BXVD_Open() - Hardware revision: M, Firmware revision: 16050f
[   31.516] *** 00:00:00.486 BXVD: BXVD_Open() - Hardware revision: M, Firmware revision: 16050f
[   31.534]     00:00:00.503 bdsp_raaga_priv: BDSP Firmware Version 12p4p0p0
[   31.594] *** 00:00:00.563 BVCE: FW v4.12.2.0 (0x040c0200) [API v5.12.0.0 (0x050c0000)][0]
[   31.611] *** 00:00:00.581 nexus_platform: initialized
[   31.612] ### 00:00:00.581 nexus_timebase: NEXUS_Timebase_P_SetSettings: Unknown sample rate 0, assuming 48000
[   31.740] NetworkTime: server changed to 'http://time.brightsignnetwork.com'
[   31.741] NetworkTime: Configuration changed.
[   31.788] commandline read: brightsign
[   31.791]    ~~~~~~~~~~~~~~~~~~~~~~~~~~| DirectFB 1.4.17 |~~~~~~~~~~~~~~~~~~~~~~~~~~
[   31.791]         (c) 2001-2012  The world wide DirectFB Open Source Community
[   31.791]         (c) 2000-2004  Convergence (integrated media) GmbH
[   31.791]       ----------------------------------------------------------------
[   31.791]
[   31.810] (*) DirectFB/Core: Single Application Core. (2016-12-09 18:32) [ DEBUG ]
[   31.847] Setting system clock to 1504813759.000000
[   31.853] NetworkTime: clock set to 2017/09/07 19:49:19.005 UTC
[   31.858] eth0: no IPv6 routers present
[   31.861] *** 00:00:00.000 platform_init: Broadcom Corporation DirectFB Platform Layer Version 7.0
[   31.861] *** 00:00:00.000 nexus_common_init: Display heap: handle=0xdf7ba8 size 410296kB - free 393912kB - largest block 393912kB
[   31.862] *** 00:00:00.000 nexus_common_init: Offscreen heap: handle=0xdf7ba8 size 410296kB - free 393912kB - largest block 393912kB
[   31.907] (*) DirectFB/Graphics: Broadcom Corporation Bcmnexus Packet Buffer GFX Driver 4.3 (Broadcom Corporation)
[   31.994] (*) Direct/Thread: Started 'BRCM NotifyDisplay' (-1) [OUTPUT OTHER/OTHER 0/0] <1048576>...
[   32.011] (*) DirectFB/Core/WM: Default 0.3 (directfb.org)
[   32.133] *** 00:00:00.271 nexus_video_output: No HDMI Rx connected.. settings will not be applied
[   32.146] *** 00:00:00.285 platform_nexus_display: HDMI hotplug event: not connected
[   32.230] ### 00:00:00.368 platform_nexus_display: Set to RGB output 0: 1 3 2
[   33.042] *** 00:00:01.180 BCHP_AVS: AVS support enabled!
[   34.764]     00:00:02.903 BHDR_EDID_RAM: HDMI EDID bytes not specified; HDMI Rx will use its default EDID
[   34.772] *** 00:00:02.910 BHDR_HDCP_PRIV: HDCP Key Set invalid/not loaded to RAM
[   34.772] *** 00:00:02.910 BHDR_HDCP_PRIV: HDCP BKsv Valid: 0
[   34.772] *** 00:00:02.910 BHDR_HDCP_PRIV: HDCP Keys loaded to RAM: 0
[   34.772]     00:00:02.910 nexus_hdmi_input_hdcp: Begin Loading Encrypted keyset...
[   34.786]     00:00:02.924 nexus_hdmi_input_hdcp: Done  Loading Encrypted keyset...
[   34.881] dhcpcd[122]: eth0: no IPv6 Routers available
[   36.737] Loading 'USB1:/autorun.brs' (32faee70c3c61223e00558f25194236ef2ed583d)
[   38.016] Bluetooth startup failed: DBus exception The name org.bluez was not provided by any .service files

8 comments

  • 0
    Avatar
    David Herde

    Any help would be appreciated. I do not know if these modules (magnum/basemodules/dsp/src/raaga/firmware/fp2011/bdsp_raaga_img.c) are from the Linux build on the player or from the web app (though I don't see a webapp module logging an error on the XD1132 as a first pass cause). But I really don't understand why it works (sort of) with a reset player and not one which has been set up for use. I also thought that landscape was the default orientation and cannot figure out why the web page is showing up in portrait mode. I expect I am doing something wrong but don't know what it is.

  • 0
    Avatar
    David Herde

    Correction- Local file networking enabled.

  • 0
    Avatar
    David Herde

    Correction- Local file networking enabled.

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    Have you tried "Enable External Data" in the HTML state?

  • 0
    Avatar
    David Herde

    Thanks for the response.

    Yes  Enable External Data is turned on.

     

  • 1
    Avatar
    Bright Scripters info[at]brightscripters.com

    If the same page shows after a factory reset, but it doesn't show after a player setup, then it could be a host name resolution issue.

    It the diagnostics web page there is a diagnostics tab, from which you can gain some insight.

    DNS Lookup on vnt517 could tell you something.

    If it fails, you could use the host's IP address instead

    http://<IP goes here>:9001/App/Ops/ui/SignInTerminal/Task/SignInTerminal/Main?kioskS....

    Or try its FQDN host name like vnt517.ourintrantet.net

     

  • 0
    Avatar
    David Herde

    You have no idea how really awesome you are.

    Not using the FQDN was the problem.

    That brought it up. (Now I just have to get it oriented correctly.)

    Thanks bunches

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    With pleasure my friend :)

     

Please sign in to leave a comment.