0

Cannot control Sharp 70LE661U with Serial Control (trailing spaces)

Player: XD1132 (firmware 6.2.94)
BrightAuthor v. 4.6.0.18

TV Serial Input Requirements (per manual):
Baud Rate - 9600
Data length - 8 bits
Parity bit - None
Stop bit - 1 bit
Flow control - None

Presentation Interactive/Serial Properties:
Port - 0
Baud Rate - 9600
Data bits - 8
Parity - None
Stop bits - 1
Protocol - ASCII
Send EOL - CR
Receive EOL - CR
Both "Invert signals" and "GPS Receiver" are unchecked

Sharp requires the RSPW1 serial command to be input initially, this was done and confirmed via Hyperterminal.

I have the POWR1 (on) and POWR0 (off) saved as two separate presentations using the following info (on, for example):

Entry Commands
Send - Serial string (EOL) - Port: 0 - String: POWR1

I can add the three trailing spaces the Sharp manual requires me to add, but it will not save in BrightAuthor.

I have tested the commands using HyperTerminal. When the trailing spaces are apart of the command, is responds correctly and the function triggers. When the trailing spaces are not added, the TV reports back errors.

Using a null modem cable, I hooked the XD1132 to HyperTerminal and can verify the player is sending the first 5 characters correctly, just not the trailing spaces.

I there a setting I'm missing that will send the trailing spaces?

Thanks!

3 comments

  • 0
    Avatar
    ^UD\_$

    Convert your commands to ascii decimals, and send serial bytes (comma separated) instead of String EOL.

    If you need to send EOL, convert that to ascii decimal as well.

     

    I hope that helped.

  • 0
    Avatar
    Brandon Newburg

    That did the trick. Thanks!

  • 0
    Avatar
    ^UD\_$

    Good deal!

    Thanks for the feedback.

    Successful closure makes our day :)

Please sign in to leave a comment.