0

Only one zone displays HTML5?

Zone one is showing an HMTL page properly (thanks to help here), but i created a 2nd HTML5 zone that points to an HTML page with accuweather code to display a weather feed.

The weather page itself works, but does not display in zone 2 on BS...

I have yet to accomplish even one thing with BS without these forums.  It is incredibly frustrating.  Any ideas for this one?

28 comments

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    If you set the first zone (the one that is currently working) to accuweather, is it showing?

    For weather we tend to use screenfeed.com, which simplify things for us. Instead of running HTML code, we simply fetch a jpg image.

    Less moving parts, and things to go wrong.

     

  • 0
    Avatar
    Don Hollen

    Thanks,

    The weather html does not show when called in the working zone.  Just black screen.

    I can't pay for a service, so i've been looking for a feed URL to point to for weather, but since i couldn't find one, i tried the code from accuweather.  

  • 0
    Avatar
    Don Hollen

    The weather page does have a javascript.  Is that the issue?

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    Anything is possible with HTML :)

    You could use the javascript console to get some insight on where the problem is.

    http://docs.brightsign.biz/display/DOC/Best+Practices#BestPractices-DebuggingWebpagesdebugging_webpages

     

  • 0
    Avatar
    Don Hollen

    I get "Inspectable WebContents", and click on the weatherfeed.html, and it shows no errors.   I feel like i'm taking crazy pills! 

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    Can you share the url that you are trying to present?

  • 0
    Avatar
    Brandon

    Are you using the Accuweather widget on an actual web server, or are you using Local Files?

    The Accuweather and The Weather Network widgets won't work as local files due to the way they rewrite the URLs.

  • 0
    Avatar
    Don Hollen
      <a href="https://www.accuweather.com/en/us/concord-nh/03301/current-weather/1211_pc" class="aw-widget-legal">
      <!--
      By accessing and/or using this code snippet, you agree to AccuWeather’s terms and conditions (in English) which can be found at https://www.accuweather.com/en/free-weather-widgets/terms and AccuWeather’s Privacy Statement (in English) which can be found at https://www.accuweather.com/en/privacy.
      -->
      </a><div id="awtd1494529574806" class="aw-widget-36hour" data-locationkey="1211_PC" data-unit="f" data-language="en-us" data-useip="false" data-uid="awtd1494529574806" data-editlocation="false"></div><script type="text/javascript" src="https://oap.accuweather.com/launch.js"></script>
  • 0
    Avatar
    Don Hollen

    on a private server, but there is the code i got from accuweather. it is on an html page on the server

     

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    The above code is not showing anything in my web browser.

    Are you able to load the page successfully in your web browser?

    Do you have a files that you could provide a link to?

  • 0
    Avatar
    Don Hollen

    works for me.

    Check it out here (test page): http://www.donhollen.com/weatherfeed.html

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    That page opens from your server, but when I save it and open from local storage, it doesn't open.

  • 0
    Avatar
    Don Hollen

    but the BS is pointing to a live server version.   both the BS and site IP are in the same range(?)  both live

     

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    I'll try to load on a player and see if the live file opens.

  • 0
    Avatar
    Don Hollen

    I tried it in my BS and nothing shows

     

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    Your page is working here.

    Have you check option "Enable external data"?

     

     

  • 0
    Avatar
    Don Hollen

    Yeah, those are the same settings i have.  I feel like i'm taking crazy pills!

     

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    Firewall issue?...

    Are you computer, and player on the same network segment?

    What is the player's firmware version, and which BA version are you on?

  • 0
    Avatar
    Don Hollen

    yes, all are on the same network (and ip range?)  not an IT guy,

     

    Model: XD230
    Unique ID: X0H46X000561
    Ethernet IP: 156.120.24.72
    Ethernet MAC: 90:ac:3f:02:7f:a7
    Ethernet IPv6: fe80::92ac:3fff:fe02:7fa7/64
    Boot Version: 4.4.15
    Firmware Version: 6.1.76

     BSA 4.6.0.18

     

     

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    Lets see if your player can find hosts on the internet.

    In the diagnostics web page, you can find some troubleshooting tools under the Diagnostics tab.

     

    You can try and ping your host donhollen.com

    Other tools are: Trace Route, DNS Lookup, and Network Configuration

     

     Can you send a link to your presentation so I can take a look?

  • 0
    Avatar
    Don Hollen
    www.donhollen.com resolved to 108.178.54.210
    PING 10/10: 42283/43022/47649us

    The presentation is on a private, non public server.  I'm in courthouse and everything is locked down.  :(

  • 0
    Avatar
    Don Hollen

    The weird thing is, i have a copy of that weatherfeed.html on the same site that is displaying HTML in another zone and working fine.  Just not the weather one.  

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

    Can you also run the Trace Route and Network Configuration?

    Can you put your last description in different words?

    When you say "site" is that a web site, or is it a physical location?

    When say "zone" is that a BrightAuthor zone?

     

     

     

  • 0
    Avatar
    Don Hollen

    Trace Route Results

    www.donhollen.com resolved to 108.178.54.210

     

    We have a website that is only accessible by people in the building (network?)  It is a drupal site.  On that site, i have an HTML page.  That page is showing fine on the site and in Zone 1 in BrightAuthor.

    The weatherfeed.html from above shows fine on the site, but will not show in Zone 2 in BrightAuthor projcet.  It is listed the same way we did the test using donhollen.com, but neither of the weatherfeeed HTML pages show in zone 2.

     

    Thanks for your help with this.  I just need a free weatherfeed for this mostly useless display.  I'm not even sure why we are using this instead of a big monitor...

  • 0
    Avatar
    Bright Scripters info[at]brightscripters.com

     

    Just for troubleshooting, can you try and load the weatherfeed in zone 1 instead of 2?

    You said: "showing fine on the site and in Zone 1 in BrightAuthor.".

    Are you testing with the BrightAuthor preview, or on the player.

     

    I can better assist if you sent over the BrightAuthor file.

    Can you open the bpf in notepad, and paste the code here?

    If better, you could instead email that to support@brightscripters.com

     

  • 0
    Avatar
    Don Hollen

    We tried it in zone one earlier in this thread.  Just black screen:

    Bright Scripters Last Friday at 11:13 AM

    If you set the first zone (the one that is currently working) to accuweather, is it showing?

    For weather we tend to use screenfeed.com, which simplify things for us. Instead of running HTML code, we simply fetch a jpg image.

    Less moving parts, and things to go wrong.

     

    Permalink
    • 0
      Avatar
      Don Hollen Last Friday at 11:31 AM

      Thanks,

      The weather html does not show when called in the working zone.  Just black screen.

  • 0
    Avatar
    Lyndon

    Try weatherbug. We also have an example on our demos page from weather underground. The accuweather feeds used to work so you could just double click on the html and play them back on your pc. But, now they have to be hosted. 

  • 0
    Avatar
    Don Hollen

    http://rss.weatherbug.com/    Site cannot be reached.

    I went to their home page and sitemap but could not find a working feed

Please sign in to leave a comment.