0

Best output mode for 1080 25P



Hi I all the documentation it says that preferred output mode is 1080 29.97p... But I am in PAL land and we shoot 25p What output settings for hdmi should I use? 50i means that there might be a de-interlacer involved - that is no good. 50p should work but it is not standard hdmi and if it is the same as the 60p, the documentation suggests de-interlacer here too... Please tell me what output settings to use! Thanks, Mats

18 comments

  • 0
    Avatar
    RokuLyndon


    If you're using 50p or 60p, then the brightsign uses its deinterlacer to get from 50i, 60i to progressive.

    if the content is 25p, then 50i or 50p is going to be the best looking output.
  • 0
    Avatar
    Mats


    Thanks Lyndon for your swift reply!
    But this is really bad news - if I run 50i there is a deinterlacer involved and if I use 50p there is a deinterlacer involved!
    It seems that the only way to get pure 1080p out of the brightsign is 29.97...
    Not even 24p works!
    If 24p(23,98p) had worked I could have conformed 25 to 24 but no the only option is 30 - I wish I had known...
    Even the cheap Tvix boxes we use can handle 24p and 25p - isn't it a sigma chip in the brightsign too?
    By the way how does BrightSign handle a 23.98p in a 29.97p project?
    Mats
  • 0
    Avatar
    RokuLyndon


    The brightsign will automaticallly do the rate conversion.

    I know we have plans on for adding 25p, but it's not there yet. The 29.97 is the only native 1080p setting where no deinterlacer is involved on the brightsign side. Does your display support 29.97 p?
  • 0
    Avatar
    Mats


    Of course the display supports 29.97p
    The problem is still to be able to run either 24 or 25p without deiterlacing. Does the brightsign add 2.3 pulldown when playing 23.29 in 29.97?
    Please figure out a way to play 25p(24p) without deinterlacer!
    Thanks,
    Mats
  • 0
    Avatar
    eaban

    Glad to hear someone else is struggling with this issue as well.  We are having a lot of problems getting 25p to display correctly due to it always passing through the deinterlacer.  I've noticed that the new models like the 1020 support 24p which is great but we still don't have 25p!  This thread was started almost 2 years ago, has there been any progress on including this feature?

    Thanks

  • 0
    Avatar
    Alex

    Deinterlacer in the new HD units is better than the previous one because of the changes in the video processing. So the quality of the end result is generally better on the new HD units. But you are still going to get better results with native resolutions 1920x1080x24p, 1920x1080x29.97p and 1920x1080x30p.

  • 0
    Avatar
    paul

    Hi,

    RokuLyndon - October 08, 2010 10:34 pm:  "I know we have plans on for adding 25p, but it's not there yet."

    When?

    Regards

    Paul

  • 0
    Avatar
    Lyndon

    Paul, clearly this feature hadn't bubbled to the top of the priority list yet. At the moment, it's not likely to be added this year. I'm currently trying to find out if it will be added in the next 6 months. 

  • 0
    Avatar
    Mark

    Status?

  • 0
    Avatar
    Lyndon

    IF you're running the latest firmware, and using the newest brightauthor, you'll get the option of doing 1080 @ 24 and 25p for the HDxx20 series and XD players. 

  • 0
    Avatar
    Mark

    Great news. I have the latest HD120 with latest firmware. However, I like to just use simple scripts. Can I do videomode 1920x1080x25p? 

  • 0
    Avatar
    Lyndon

    Yes

     

  • 0
    Avatar
    Mark

    Woo-hoo. Yet more great news. 

    I expect the resolutions page in the FAQ support to be updated accordingly...

  • 0
    Avatar
    Mark

    Interestingly, since updating the firmware once I include a simple script (no matter what I set the videomode to) my content no longer plays back. Removing the script and all is fine. I've played this content back with that script just minutes ago prior to updating to 4.4.82. Here are the autorun.brs contents:

    v=CreateObject("roVideoPlayer")

    p=createobject("roMessagePort")
    v.SetPort(p)

    'videomode settings below currently disabled
    mode = CreateObject("roVideoMode")
    mode.SetMode("1920x1080x25p")

    start:
    list=ListDir("/")

    for each file in list
    if ucase(right(file,3)) = "MPG" or ucase(right(file,3)) = "WMV" or ucase(right(file,3)) = "MOV" or ucase(right(file,3)) = "MP4" or ucase(right(file,3)) = "VOB" or ucase(right(file,2)) = "TS" then
    v.PlayFile(file)

    loop:
    msg=wait(0,p)
    if type(msg) <> "roVideoEvent" goto loop
    if msg.GetInt() <> 8 then goto loop
    else
    print file
    endif

    next


    goto start

  • 0
    Avatar
    Mark

    Fixed. I don't know what was wrong with the above posted script, but I instead used the playall1080 script (https://www.brightsignnetwork.com/download/Scripts/playall1080.zip). This script is more complicated and probably more than I need to just autoplay and loop 1 .mov, but it's working.

    The 25p content plays back fine and looks much better with this videomode 25p and newer firmware. Very nice. 

  • 0
    Avatar
    Mats

    I started this thread 3 years ago and my 4 HD210 are still on the shelf because I cannot play 25p or 24p.

    Now it seems that all the players but mine has been updated to support 25p.

    How can it be so hard to add 25 or 24p its there is all other players.

    Please why dont you add it to all players?

    Mats

  • 0
    Avatar
    Romeo

    There is no plan to add 25p or 24p to the Hdx10 range. Only the HDx20 and XD range support these resolutions.

    Regards,

    Romeo

     

  • 0
    Avatar
    sven anderson

    The addition of 25p support is such great news.  I really look forward to the next show that I set up with these in 25p mode - I'm testing now in the studio and it's so good to see video without any interlacing / framerate artifacts.  Thanks for getting this up and runing!

Please sign in to leave a comment.