0

Time zones and incorrect time



Hello, I've almost setup my HD210s the way I want, but am struggling with the time they're showing. My boxes are in a corporate active directory domain, firewalled from the outside world. I've pointed my boxes to look towards our internal NTP server as external sources are blocked, but the time is being displayed 17 hours too slow. E.g. 3:00PM Thursday 29th April, is being displayed as 10:00PM Wednesday 28th April. I've played around with multiple time zones in BrightAuthor, however they seem to make no difference. What else can I do? If it is an issue with the internal NTP I'm talking to, is there a way to use a proxy for only the NTP server? I read somewhere that you can use a proxy specifically for RSS feeds (which also might be handy), and thought I might do something similar.

13 comments

  • 0
    Avatar
    RokuLyndon


    Debug script

    Please download and run this autorun.brs on your unit so we can capture some settings from the unit. We can see what timezone the unit is using. I'll check on using proxy just for the time.
  • 0
    Avatar
    RokuLyndon



    Send the results tosupport@brightsign.biz .

  • 0
    Avatar
    Sylvain Bigand



    NTP vs HTP

    I want to draw the attention of the development team on this issue. Indeed, it is sometimes difficult for practical reasons in an IT environment to impose NTP. The ideal would be to only use the HTTP protocol (fully on layer 7 of the OSI scheme). There is precisely one solution, that we have already implemented in another context and that can synchronize the local clock with the timestamp included in the http headers. Look at this:

    http://www.clevervest.com/htp/ 

    The solution exists for Linux and Windows, it should not be any problem to implement it on the firmware of players. Thus it becomes possible to communicate only through a single TCP port with the server BSNM and thus reduce adhesions infrastructure. But it remains possible with this solution to specify multiple time source servers providing more fault tolerance and precision in the calculation of the final time. The solution here is very well done and there are similarities with NTP, especially as we usually do not need extreme accuracy for this type of application.

    This greatly simplifying the deployment of Roku STB and facilitates relationships with the IT staff ...

    Sylvain Bigand
    TMM Communication

  • 0
    Avatar
    RokuLyndon


    Sylvain,

    I forwarded your post to Mike, Rob, and Ted.
  • 0
    Avatar
    shaun


    Hi Lyndon,

    Just making sure you received my email with the log file. Previously I've had issues sending and receiving emails from Roku.
  • 0
    Avatar
    RokuLyndon


    Shaun,

    Can you try a test for me? Please try setting the IP address of the brightsign manually. You can do this with a script. There's a link to one in the network sticky post that's in this forum.
  • 0
    Avatar
    shaun


    Lyndon,

    I ran the manual IP script and was able to change the brightsigns settings. I pinged the box at its manually entered IP to verify.
    From BrightAuthor I then published a copy of my presentation to the brightsign using the Local Storage option.

    The result was the same. The time was still out by 17 hours.
  • 0
    Avatar
    RokuLyndon


    Ok, let's try this.

    The attached included three files. Edit the autoplay.bsp file with any text editor, and set the date and time in it. Then, run these three on a flash card. It'll manually set the date and time on the player and display the date and time on the screen. Once that works, I'd remove the three files from the flash card, and try your project again.

    Use this to set the time, and test again
  • 0
    Avatar
    shaun


    Done. At the time the display showed the data and time I had entered.

    Then once I placed the project files back on the card it showed the incorrect time again.

    EDIT: OK it is now out by 8 hours, not 17. We're getting somewhere.
  • 0
    Avatar
    shaun


    It's fixed.

    I redid the date/time changes you mentioned, but this time instead of changing the time I just manually set the timezone to +10 and bam!

    Thanks for your support Lyndon.
  • 0
    Avatar
    PeterCassidy


    I had the same problem on my HD210. It displayed 88:00. This solution of running the special scripts above along with resetting the time zone worked. I had to set the time to GMT-5 for CDT. I assume Shaun meant he set his timezone to GMT+10

    Peter Cassidy
  • 0
    Avatar
    Dk Aust.


    Hello,

    I have read through this page and it all sounds good, one thing... where the hell do I enter the date and time within that autorun file?



    cheers.

    DK
  • 0
    Avatar
    RokuLyndon


    Use this to set the time, and test again

    Using these files, you would set the date and time in the autoplay.bsp playlist file, then copy all three files to your flash card.
Please sign in to leave a comment.