0

video in HTML5 page

According to http://html5test.com/ the built in HTML5 browser of the XD devices (Chromium 18) supports Video elements (H.264, MPEG4, OGG, WebM).

I tried H.264 and WebM without success.

 

Is video embedded in HTML5 pages supported in XD-devices with firmware 4.4.34?

 

14 comments

  • 0
    Avatar
    Alex

    Please export the presentation (File - Export) that you try to play on the XD unit, and send it to us.

  • 0
    Avatar
    Armin Brunner
  • 0
    Avatar
    chris mundus

    Is there any update on this? I would like to loop an mp4 inside of an html zone but the standard html5 video tags dont seem to do anything.

  • 0
    Avatar
    Lyndon

    Chris, can you send me a sample of what's not working for you as well? Is yours a remote page, or can you test publishing a local copy of this same page as well? That is, do you have the html file and assets in a folder on your computer, and can you try publishing the html file locally. BrightAuthor will copy the assets associated with the web page, if the page is in a folder that contains the assets, including any subfolders that are in the same directory as the html file. 

     

    The copy of html assets is indiscriminate. So, you should't put the html file in your documents folder, for example, or the copy will copy everything in that folder. 

  • 0
    Avatar
    Alex

    Armin, the current html5 video playback on the xd requires that the video content be local. So, you can't currently play youtube for example. But, if you built an html site and had assets on your system, you can publish the html file and all of the assets from the local folder, and subfolder would be uploaded to the player. This will be updated later in the this quarter so that you can playback html5 video from remote locations.

  • 0
    Avatar
    chris mundus

    Ah gotcha! It works with local files. I suppose we will have to wait for the remote locations...

  • 0
    Avatar
    chris mundus

    So does the browser that we are using on here not currently support placing elements over the video? It seems to be ignoring my z-index.

  • 0
    Avatar
    Lyndon

    Chris, I believe it should. Can you send me a sample html file with what you're trying to do, and I'll have someone look at it identify if we have a bug or if there's something else causing the behavior you're seeing. 

  • 0
    Avatar
    Sigl

    Hello there. Can someone send me a video that is actually working? I tried different mp4 encoded formats locally but none of them worked?! Or at least send me the exact codec information? Best, konrad

  • 0
    Avatar
    Lyndon
  • 0
    Avatar
    Alex Campbell

    Is there any support for remote files yet? I have a html5 site with an embed .webm file that I would like to play from the player, or is this still not possible?

  • 0
    Avatar
    Lyndon

    Yes, you can playback files on remote sites. But, we don't support .webm codec. 

  • 0
    Avatar
    Curdin Krummenacher

    Hi, can you please provide more detail about how to make video playback from remote work? I can get local h.264 files to work fine but when hosted elsewhere the logs show events 16 / 30. The playback areas remain empty and the time does not update in player. I've copied the relevant logs below. Any advice would be greatly appreciated.

    Currently testing on an XD2 (XD1032) - test url is https://te-papa.github.io/offline-interactive/

     

    [ 149.362] Playing: https://te-papa.github.io/offline-interactive/media/demo-audio.mp3
    [ 149.365] MediaStreamer::SetPipeline called with gst:https://te-papa.github.io/offline-interactive/media/big_buck_bunny.mp4?playpump=1469448&maxbitrate=0&alternateurl=
    [ 159.373] Gstreamer::Connect: aborted
    [ 159.373] FireEvent 16 (line 1074)
    [ 159.373] FireEvent 30 (line 1075)
    [ 159.375] TIME: PlayFile = 10.012739
    [ 159.375] [INFO] [source https://te-papa.github.io/offline-interactive/index.html:0]: Application Cache NoUpdate event
    [ 159.377] ### 00:02:12.740 nexus_audio_decoder: Decoder not started or suspended
    [ 159.386] MediaStreamer::SetPipeline called with gst:https://te-papa.github.io/offline-interactive/media/demo-audio.mp3?playpump=149fbc8&maxbitrate=0&alternateurl=
    [ 169.392] Gstreamer::Connect: aborted
    [ 169.392] FireEvent 16 (line 1074)
    [ 169.392] FireEvent 30 (line 1075)

     

    UPDATE:

    I tried to make the files "more local" by injecting the video content as a dataURI and using IndexedDB to serve the file. Neither to any avail. I'd be very grateful for any advice.

  • 0
    Avatar
    Nou Chee Her

    Chromium up to this day does not support H264, even on http://html5test.com/, only VP8, VP9 and Ogg Theora. BrightAuthor is only using the latest version of my Internet Explorer (11) to render under it's preview feature, which means that you cannot rely on it for Chromium support or proper testing. I'm quite disappointed that Chromium wasn't natively built into BrightAuthor's preview...

    I'm still waiting on my BrightSign unit to arrive to fully test things out, but technically you wouldn't be able to stream H264 via HTML5 on the players because it's not supported on Chromium, unless BrightSign built additional support to combat it.

Please sign in to leave a comment.