0

Sync with XD1030 and XD230

Hi
I am trying to sync an XD1030 with an XD320 according to the tutorial "Creating a Multi-screen Synchronized Presentation using BrightAuthor". The players are connected via ethernet over a switch.  


XD1030 is my master, its IP is set in Presentation Properites as 192.168.1.100, UDP Port: 5000
XD230 is my slave, its IP is set as well in Presentation Properties as 192.168.1.101, UDP Port 5000

From the Media Library I used "nature9.jpg" as a still image and "NETWORK.mpg" as movie to be synced. 
The master displays the still image while waiting for a button to be pressed on the BP200.When the button is pressed a state change to NETWORK.mpg is triggered as well as a command in the advanced tab of the button event [Link, Synchronize, Start]

The slave also displays "nature9.jpg" while waiting with a synchronize event with the keyword "Start". The next state would be NETWORK. mpg. 

All works fine on the master, but the slave keeps showing the nature image. I ran the fullregistryclean script on both players with no luck. 

Anyghing else that can be done?

thx

RFL

13 comments

  • 0
    Avatar
    Lyndon

    Presentation properties isn't the ip address of the unit. It's the ip address the unit should send the udp/sync commands to. Just select the ration button for broadcasting to all available subnets. That way, it doesn't matter what IP address the master is set to or even if the master doesn't have an assigned iP.

     

    Unless the ip address of your slave unit is 192.168.1.100, this is  your issue. 

  • 0
    Avatar
    RFL

    Thank you for the help. I ran "BrightSign Unit Setup" on master and slave again and made sure that "Obtain an IP automatically"  is checked. In the project setup I made sure, it broadcasts UDP to all available subnets. 

    The result is, that it doesn't work the first time but every time thereafter...
    Any hint for that behaviour? 

     

  • 0
    Avatar
    Alex

    Please send your master and slave presentations for review. Send just the *.bpf files.

  • 0
    Avatar
    RFL

    Here you go, the master and slave .bpf files. Thx

  • 0
    Avatar
    Alex

    Copy the attached autorun.brs file to blank SD cards, power up each unit with its own SD card. This script will clean all settings from the registry of the units. Do not create setup files after that. I've rebuilt the projects. Publish these presentations to blank SD card, insert SD cards in the players, power them on, and test.

  • 0
    Avatar
    RFL

    i did as described but the result is the same. 
    the master starts the firtst time without slave. 
    from the second time on master and slave start in sync.  

    plus, after the first time, the button is pressed, the startimage flickers and "slides" to the left.
    afterwards, the transition is a "clean" change...  

  • 0
    Avatar
    Alex

    Can you use a single Ethernet cable to connect two units with each other, power them up and retest.

  • 0
    Avatar
    RFL

    That gives the same result. It's synced the 2nd time. 

  • 0
    Avatar
    Alex

    I've tested the presentations on my units. The playback is OK from the first attempt.

  • 0
    Avatar
    RFL

    Is there any way to see the code that BrightAuthor generates? Or is it precompiled in machine language?

  • 0
    Avatar
    Alex

    You can publish a presentation and open the autorun.brs file in notepad to see the code. Take a look at http://support.brightsign.biz/entries/23275667-BrightScript-Syntax-Highlighter-Extensions

    The autorun.brs file is the Application that runs on the firmware. It takes advantage of all the firmware objects that are documented in the object reference manual on our support site. The main autorun.brs and other system .xml files are utilized to configure the Application for your specified schedule and presentation.

  • 0
    Avatar
    patrick131

    I have the same issue, syncs on 2nd loop.  Was there a resolution to this?

  • 0
    Avatar
    Alex

    Please send the project files for review.

Please sign in to leave a comment.