0

Real troubles with UDP Volume change sync

Hello,

 

I'm having real issues with the UDP Audio Sync. The overall UDP work fine. It's enabled in presentation properties and also with enhanced sync. For both Slave and Masters.

The setup is 1 Master + 7 Slave's with Projector control over RS-232C.

Only issue now is the volume Sync.

I made keyboard events for both increment and decrement volume - working on master. On the slave it basically mutes the audio so something is working. But after the input, it'll always be muted on the slave - until restart.

There is different keywords for different actions.

I made screenshots of the settings I've made.

Thanks in advance,

Kunnar

Genera presentation UDP settings:


Master:



Slave:




12 comments

  • 0
    Avatar
    Bright Scripters

    Thanks for the screen shots. It saves a lot of the back and forth Q&A.

    I'd be interested to know whether you are getting the same behavior on both HDMI and Analog.

    You could also try and modify the Zone Volume, instead of the Connector Volume. You may get a better behavior that way.

     

    In addition, I'm seeing that if a player is rebooted, its audio level would get out of sync from the rest, but one thing at a time...

     

  • 0
    Avatar
    Kunnar

    Hi,

     

    thanks for that. Yeah the Zone Volume worked perfectly. Audio output reacted the same.

    One more thing, I've noticed. If the presentation is played in full, the projectors will close as programmed on last image (fullpageblack, turns serial off). But if I interrupt the play with keyboard button (it will go to the same image, which closes the projector) but at first run it doesn't close projectors, but I need to re-play the video and then it'll close? Even though it's programmed the same, as playing full presentation?

    That's what I've been noticed. Which is strange. I'd share the presentation file, if needed.

    For the volume sync, would that work, if in every start of the video, it'll call out the "volume1" User Variable? Should that work? Did I made it correctly? As it's kind of new for me still.

     




  • 0
    Avatar
    Bright Scripters

    Glad to hear that volume control now works.

    Initializing all slaves volume upon master startup, is a good idea.

    If all players wake up at the same time (with a main power switch), you may want to add a small pause delay, to the master startup, to ensure that all slaves are ready by the time the master is initializing the volume.

    Also, if a UDP gets lost for some reason, slaves' volume level may get out of sync. You should send absolute volume level from the master to the slaves, instead of a increment/decrement.

    It would be easier to analyze the projector shutdown issue, if you shared your presentations: master and slave.

    Actually, I'm assuming all projectors are shutdown by the master; correct?

  • 0
    Avatar
    Kunnar

    Hi,

    Well, I meant the Audio Sync before Video starts to play.

    But there will be multiple videos for multiple buttons, so I'm not sure how good idea is that, but basically it'll sync the volume at the start of every video in each slave. But every time the video starts to play, it syncs to user variable. Is it configured correctly?

    No, every slave will turn off and on each projector, connected via Serial. I have 2 fullpageblack images, in which the entry event sends serial event to projector. One image for turning on and other for turning off. But you can see from the presentations. I'm making the overall logic for the whole setup now.

    https://www.dropbox.com/sh/bnlzqv2trzjuicv/AACqzd6-bz49VQaY_hb_wZxla?dl=0

     

  • 0
    Avatar
    Bright Scripters

     

    Seems ok to me.

    There is no need to assign a value to variable in the UDP event, since you are not sending a numeric value from master to slave.

    Looks like entering the video, with an initialized volume level works, but it does depend on the requirements. Do you need the system to remember the last volume level used, or start fresh with the same default audio level.

    In my mind, it would be better if the volume user variable, resided in the master, and was sent to all slaves at startup. That way, you would have a single place to set the initial volume, without having the change all slaves, if you need to set a different level. 

    I noticed that the presentation video mode is set to 60i. Unless there is a very good reason to use interlaced video, you may want to look at using 60p, or 30p, depends on the content.

     

  • 0
    Avatar
    Kunnar

    Hi,

    Well, for an update. Seems that everything is working with the logic.

    But I ran into issue. I had 3 players with firmware - 7.0.60 -> None of them doesn't react to UDP events. I there any known issue with that?

    I tried even to make completely new presentations to them, but no effort. Nothing happens for UDP commands.

    Other players - running on 6.something.something works as charmed.

     

    Can I somehow downgrade them?

  • 0
    Avatar
    Kunnar

    Sorry, it seems that this firmware doesn't do any events.

    Tried a new presentation with 2 images, running 2 timeouts, and nothing happens.

  • 0
    Avatar
    Kunnar

    Ahhh, sorry, got older firmware from BrightAuthor. Thanks!

  • 0
    Avatar
    Allen H. Porter

    All players are on the same subnet?  We have sometimes seen that the network is blocking the UDP words.  File - Presentation Properties - Interactive.  Is the IP set to 255.255.255.255 or to a Multicast IP?  Everyone listening on the same port?

  • 0
    Avatar
    Kunnar

    Yes. It seems that it's only happening with players running this 7. firmware.

  • 0
    Avatar
    Kunnar

    Even this simple logic doesn't work with 7.0.60.

    Downgrading also didn't help via BrightAuthor.

  • 0
    Avatar
    Bright Scripters

    This is too simple not to work.

    Check your image resolution.

    Make sure your media files are playable.

    You could simply place them on a blank SD card and reboot. They should play in sequence.

     

Please sign in to leave a comment.